The TORCS Racing Board
Username: Password: Remember Me?
Lost Password Register
Author: kimi | Created: 2009-03-14 17:15:18
Subject: trackgen/trackeditor problems: FATAL: ac_to_gl: Unrecognised token 'SURF 0x30 ' (10)
Hi all,

I am creating a torcs track with trackeditor. I had no problems after recognizing a fatal mistake in the xml file (wrong category).
But now, fully without me knowing why, trackgen will produce a "broken" file, that's at least what I think, because torcs gives me this:

seba@Sebastian:~/Spiele/torcs/trackeditor$ torcs
Visual Properties Report
------------------------
Compatibility mode, properties unknown.
WARNING: grscene:initBackground Failed to open shadow2.rgb for reading
WARNING: no shadow mapping on cars for this track
FATAL: ac_to_gl: Unrecognised token 'SURF 0x30
' (10)

>WARNING: grscene:initBackground Failed to open shadow2.rgb for reading
isn't the problem, it works if only this error message is given.

Trackgen doesn't give any error messages:

seba@Sebastian:~/Spiele/torcs/trackeditor$ trackgen -c road -n hohentwiel -a
Changing to /usr/local/share/games/torcs
++++++++++++ Track ++++++++++++
name = hohentwiel
author = heni
filename = tracks/road/hohentwiel/hohentwiel.xml
nseg = 706
version = 4
length = 2734.970947
width = 9.000000
pits = 24
XSize = 767.214417
YSize = 691.316589
ZSize = 0.000000
Delta X = 0.000000
Delta Y = 0.000000
Delta Z = 0.000000
Delta Ang = -0.000002 (-0.000099)
=== Indices Array Size = 31280
=== Vertex Array Size = 93840
=== Tex Coord Array Size = 62560
=== Indices really used = 10566
GenerateMesh: right, reverse order, interior
Relief: 0 vtx, 0 seg
Load Chains
Segments = 706
xmin = 16.157684 ymin = 13.500000
xmax = 722.714417 ymax = 668.909058
Chains = 1
1412 Nodes
Renum Nodes, Triangles, Sides
GenerateMesh: left, normal order, exterior
Relief: 0 vtx, 0 seg
Load Chains
Segments = 710
xmin = -50.000000 ymin = -50.000000
xmax = 817.214417 ymax = 741.316589
Chains = 2
1617 Nodes
Renum Nodes, Triangles, Sides


I just don't know what's the problem. anyone here who does?

desperate regards,

kimi

If anyone is interested in the xml-file:
http://files.filefront.com/hohentwielxml/;13466402;/fileinfo.html

there seems to be a similar problem after editing the ac file with blender:
http://www.nabble.com/Torcs-crashes-after-editing-my-track-in-blender-td16529659.html
Last Edited: 2009-03-14 22:12:44 by kimi
    Author: kimi | Created: 2009-03-14 22:12:29
    Subject: Re: trackgen/trackeditor problems: FATAL: ac_to_gl: Unrecognised token 'SURF 0x30 ' (10)
    Must the problem be a problem with the xml-file? I just couldn't find a mistake... But theoretically it must be, becaus it can't be trackgen's mood?! and it hasn't worked since a specific point in the past, i think today afternoon. I restarted trackeditor, the computer, so this is sure not the problem ;)

    cheers,
    desperate kimi
    Last Edited: 2009-03-14 22:12:29 by kimi