The TORCS Racing Board
Username: Password: Remember Me?
Lost Password Register
Author: dummy | Created: 2017-05-09 09:13:32
Subject: My Linux test race bugs fa1, mouse, wdbee
Fa1:

Either remove logo.rgb from the Makefile or ship a logo.rgb.

Crashes my race right away when starting. I asume it's because there are
no Forza setups included.



Mouse:

Makefile in folders 0,1: beautiful "clkdtm" is now the ugly "car5-trb1" ;)

And check those "ROBOT =" lines. I found old mices and even Axiom_2016 in
there.



Wdbee:

unitvehicle.cpp:3078:79: error: no matching function for call to
‘TRacingline::MakeSmoothPath(TVehicle*, TTrackDescription*, TParam&,
TRacingline::TOptions)’
(this,&TrackDesc, Param,
TRacingline::TOptions(BumpMod,AvoidWidth,999,true));

unitracingline.h:66:8: note: bool TRacingline::MakeSmoothPath(PVehicle,
PTrackDescription, TParam&, TRacingline::TOptions&)
bool MakeSmoothPath(
^
unitracingline.h:66:8: note: no known conversion for argument 4 from
‘TRacingline::TOptions’ to ‘TRacingline::TOptions&’

my solution for all 4 MakeSmoothPath() occurences in unitvehicle.cpp:

TRacingline::TOptions optsR(BumpMod,AvoidWidth,999,true);
// Calculate a smooth path as right racingline
pCommonData->Racingline[cRL_R].MakeSmoothPath
(this,&TrackDesc, Param, optsR);



Last but not least:

Who spams the console? I bet it's Andrew as usual :)

Last Edited: 2017-05-09 09:13:32 by dummy
    Author: firechief | Created: 2017-05-09 09:27:53
    Subject: Re: My Linux test race bugs fa1, mouse, wdbee
    > Fa1 Crashes my race right away when starting. I assume it's because there are
    no Forza setups included.

    Yes that was my thought as well. It does demonstrate the value of a decent "default" setup, as if the track-specific one isn't included for whatever reason at least the car should be able to run the race.

    > Who spams the console? I bet it's Andrew as usual :)

    I'm not seeing any console spam. There's some stuff printed at load time, mostly by wdbee_2016, but nothing at all during the race. Then again, I've only had time to run a few laps, perhaps the spam will appear if I let it keep going.
    Last Edited: 2017-05-09 09:27:53 by firechief
    Author: timfoden | Created: 2017-05-09 21:10:16
    Subject: Re: My Linux test race bugs fa1, mouse, wdbee
    >Makefile in folders 0,1: beautiful "clkdtm" is now the ugly "car5-trb1" ;)
    >And check those "ROBOT =" lines. I found old mices and even Axiom_2016 in
    there.

    Haha. OK, I'll sort those problems out for the start of the season.

    Cheers, Tim.
    Last Edited: 2017-05-09 21:10:16 by timfoden