The TORCS Racing Board
Username: Password: Remember Me?
Lost Password Register
Author: phi | Created: 2017-08-22 19:02:28
Subject: FA1 Freezes TORCS
This time it was 3 times, about 15-20 seconds each. It is very hot this time of year, but this freezing does not help much to refresh.
Last Edited: 2017-08-22 19:02:28 by phi
    Author: firechief | Created: 2017-08-22 19:02:52
    Subject: Re: FA1 Freezes TORCS
    Yep it happens every time it pits :\
    Last Edited: 2017-08-22 19:02:52 by firechief
    Author: wdbee | Created: 2017-08-26 15:38:40
    Subject: Re: FA1 Freezes TORCS
    Running the race on my laptop I also so these 20 seconds gaps in the race. On my Desktop it is about 2 seconds.

    But to be honest, it is not only the fa1 bot that causes such freezings! I see it as well if one of the axioms is stuck.

    Wolf-Dieter
    Last Edited: 2017-08-26 15:38:40 by wdbee
      Author: phi | Created: 2017-08-26 17:11:35
      Subject: Re: FA1 Freezes TORCS
      Yes, I've recently noticed that something goes on like this. I do not know which robot (or robots) does this, but I notice it when there is a lot of confusion with several cars trying to get back on track.

      EDIT: But in TRB races I only see the FA1 do that.
      Last Edited: 2017-08-26 17:17:07 by phi
      Author: firechief | Created: 2017-08-27 02:56:04
      Subject: Re: FA1 Freezes TORCS
      Regarding the Axioms I wouldn't have a clue how to fix that problem, but I'll probably stop running them at the end of this season - either that or convert them to USR's code.

      I still haven't had the time needed to really understand how Mouse works, I've just tinkered around on the edges with Axiom, and while it was fun bringing a Mouse-based bot back into the competition there's really no need now since Tim's rejoined, especially as I expect his robots to be completely outperforming Axiom in every way by season's end.
      Last Edited: 2017-08-27 02:56:04 by firechief
      Author: phi | Created: 2017-09-11 19:07:11
      Subject: Re: FA1 Freezes TORCS
      I caught a rare situation where one Wdbee got behind another without gas. Both started to move at slow speed, causing the TORCS to drop the FPS below 1 (on my machine, of course) until the situation did not dissolve.
      Last Edited: 2017-09-11 19:07:11 by phi